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.1. ANEXO A: CONFIGURACIONES  

 

1.1 ECLIPSE 3.0 Y EL VISUAL EDITOR 

 

Para crear la interface grafica de la aplicación cliente desarrollada para este trabajo 

de grado se utilizó el ID Eclipse 3.1 con el plug-in VE-runtime-M20041116 (Visual 

Editos). Es necesario realizar la siguiente instalación para su óptimo desempeño: 

 

Descargar (http://www.eclipse.org/downloads/index.php) los archivos: 

 eclipse-SDK-3.0.1-win32 

 emf-sdo-runtime-2.0.1 

 GEF-runtime-3.0.1 

 VE-runtime-M20041116 

 

Para instalar eclipse se creo una carpeta en el directorio raíz C:\ con el nombre 

eclipse3.0.1 y se descomprimió el archivo eclipse-SDK-3.0.1-win32 en ella. Esta 

acción crea una carpeta con nombre eclipse. 

 

Se procedió a instalar la librería emf-sdo-runtime-2.0.1, GEF-runtime-3.0.1 y el 

plugins VE-runtime-M20041116. Se debe conserva la jerarquía de directorios. En 

los tres casos se el directorio para descomprimir es C:\eclipse3.0.1. 

 

Para activar el plugins VE-runtime-M20041116 se debe iniciar eclipse y activar 

desde el menú Windows/Costomize Perspectiva la opción java como muestra la 

figura.1 

http://www.eclipse.org/downloads/index.php
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Figura 1 Activacion Java menú windows/costomize Perspectiva 

 
La figura 2 muestra el resultado final de la instalación. 
 

 
Figura 2. Instalación 

 
De esta forma se consigue trabajar con el visual editor de eclipse como se muestra 

en figura 3, que incluye la interface grafica de cliente, también llamado en este 

trabajo de grado como MEDIADOR. 
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Figura 3 visual editor de eclipse 

 

1.2 ECLIPSE 2.1.0, JBOSS 3.2.1 Y LOMBOZ 2.1_O2 

 

1.2.1 INSTALAR ECLIPSE 2.1 

 

Para instalar eclipse se creo una carpeta en el directorio raíz C:\ con el nombre 

eclipse2.1 y se descomprimió el archivo eclipse-SDK-2.1-win32 en ella descargado 

desde la página: http://www.eclipse.org/downloads/index.php. Esta acción crea una 

carpeta con nombre eclipse y dentro ella el ejecutable de eclipse. 

 

Eclipse no incluye en entorno de ejecución Java (JRE). Se Necesita como mínimo 

tener instalada una versión 1.3 del JDK en la máquina. 

 

 

http://www.eclipse.org/downloads/index.php
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1.2.2 INSTALAR JBOSS 

Se descargó JBOSS listo para ejecutarse. Como JBOSS viene con una sencilla 

base de datos embebida (Hypersonic) y un servidor Web (JBossWEB o Tomcat) se 

utilizo sin ninguna configuración inicial. Las descargas se pueden realizar desde la 

página de descarga JBOSS http://www.jboss.org/downloads.jsp. Para este trabajo 

de tesis hemos utilizado la versión JBOSS-3.2.1 con el servidor HTTP interno 

JBOSSWeb Jetty.  

 

Primero descomprime este fichero jboss-3.2.1.zip en el directorio  raíz. Esto creará 

un directorio llamado jboss-3.2.1 con los subdirectorios bin, client, docs, lib y 

Server. 

 

Se puede activar el servidor de aplicaciones desde línea de comando 

desplazándose hasta el directorio bin y ejecutando el archivo run.bat asegurándose 

que las variables de entorno JBOSS_HOME, JAVA_HOME y CLASSPATH o 

desde el entorno Eclipse como se vera mas adelante. La figura 4 muestra el servidor 

de aplicaciones activo. 

 

Figura 4 servidor de aplicaciones 

http://www.jboss.org/downloads.jsp
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1.2.3 INSTALAR LOMBOZ 

Para poder ejecutar JBOOS desde Eclipse se necesitó un plug-in, y para este 

trabajo de grado hemos utilizado lomboz.21_02.zip que está disponible en 

http://sourceforge.net/projects/lomboz o en http://www.objectlearn.com/index.jsp. Se 

descomprimió este fichero dentro del directorio eclipse para que se instale en la 

carpeta plugins. 

 

En el directorio C:\eclipse2.1/eclipse/plugins/com.objectlearn.jdt.j2ee/servers se 

encuentran varios ficheros de configuración para varios servidores. Para este 

trabajo de grado se utilizó el archivo de servidor jboss321all.server, disponible en 

http://www.programacion.com/cursos/jap_aplic_jboss/classes/jboss321all.server. Se 

copio el archivo jboss321all.server en este directorio. 

 

En al figura 5, se puede ver un fragmento del fichero jboss321all.server utilizado 

para la configuración:  

 

Figura 5 codigo fichero jboss321all.server 

http://sourceforge.net/projects/lomboz
http://www.objectlearn.com/index.jsp
http://www.programacion.com/cursos/jap_aplic_jboss/classes/jboss321all.server


 

 

8 

1.2.3.1 Configurar LOMBOZ 

Para configurar eclipse se ejecutó eclipse y se procedió a realizar los siguientes 

pasos: 

 

 Menú Windows > Open Perspective > Java como se ve en la figura 6. 

 

Figura 6 Menú Windows > Open Perspective > Java 

 

 Menú Window > Customize Perspective > Other, selección sub-nodo Lomboz 

Actions.figura 7 . 

 

Figura 7 Menú Window > Customize Perspective > Other 
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Esta acción genera que aparezca un nuevo icono en la barra de herramientas 

superior y un contendor de módulos en la parte inferior cuando se acciona sobre la  

Figura 8 

 

 

Figura 8 icono contendor de módulos 

 Con la vista disponible de Lomboz J2EE. En Window > Customize 

Perspective. Se selecciona File > New sub node. Y se activa todos los nodos 

que empiecen con Lomboz. Figura 9  

 

 

Figura 9 activacion de nodos con Lomboz 
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 Selección de Console en Window > Show view. Se mostrará la vista Lomboz 

J2EE y otras más como se ve en la figura:10 

 

Figura 10 la vista Lomboz J2EE 

Esta acción genera que estén disponibles todas las opciones para Lomboz bajo el 

menú File > New > como muestra la figura.11. 

 

Figura 11 opciones para Lomboz 

 

1.3 Configurar JBOSS para ejecutarlo desde Eclipse 

Primero se configuró las selecciones de desarrollo Java, porque Lomboz requiere 

diferentes directorios para los códigos fuente.  
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En Window > Preferences > Java > New Project. Se debe tener en cuenta los 

siguientes procesos: 

 Introduce src y bin como nombres de esas carpetas, que serán por defecto. 

Por favor, no se debe modificar estos nombres ya que son necesarios para 

algunas de las tareas de Lomboz. También debes asegurarte de que la variable 

de entorno JRE_LIB apunta a la librería JRE. Figura 12 

 

Figura 12 configuración Jboss 

 En Window > Preferences >Lomboz, se debe asegura que la variable Tools.jar 

esta bien referenciada.figura 13  

 

 

Figura 13  configuración variable Tools 
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 En el sub-nodo server definitions bajo el nodo Lomboz. Se selecciona JBOSS 

3.2.ALL bajo Server types y el resto de las opciones se rellenarán después de cargar 

el fichero de configuración jboss321all.server., figura 14  

 

Figura 14 sub-nodo server definitions 

 

 Verificar las variables de classpath en  Window > Preferences > Java > 

Classpath Variables, figura 15 

 

 

Figura 16 variables de classpath 
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1. Apache-AXIS 1.1 

 

Se descarga el archivo axis-1_1.zip disponible en http://ws.apache.org/axis/ y se 

procede a su instalación teniendo en cuenta: 

 

 Se crea un archivo de nombre axis en el directorio raíz y se descomprime el 

archivo axis-1_1.zip en el. Esta acción crea un directorio con nombre axiz-1_1 y 

bajo el la siguiente estructura de directorios: docs lib LICENSE README 

release-notes.html samples webapps xmls. Y bajo el directorio lib: axis-

ant.jar commons-discovery.jar jaxrpc.jar saaj.jar axis.jar commons-

logging.jar log4j-1.2.8.jar wsdl4j.jar. 

 

1.1. Configurar AXIS con JBOSS 

 

Para configurar Jboss con Axis, primero se crea una directorio con nombre 

webapps en C:\jboss-3.2.1\server\all\deploy.y se copia el directorio axis que esta 

dentro de C:\axis\axis-1_1\webapps en el, para luego renombrarlo como axis.war. 

De esta forma JBOSS puede reconocerlo como una aplicación web y así el 

contenedor web pueda desplegarla en tiempo de ejecución. 

 

Después de arrancar el servidor JBOOS desde eclipse se puede comprobar la 

instalación cargando http://127.0.0.1:8080/axis/ en el explorador como muestra la 

figura 17. 

 

http://ws.apache.org/axis/
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Figura 17 servidor JBOOS 

 



 

 

15 

 

 

 

 

 

 

 

 

 

 

 

ANEXO B: MANUAL DE USUARIO MEDIADOR MEPCC  
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1. MEDIADOR MEPCC. 

 
Esta aplicación llamada Mediador EPC para la Construcción MEPCC, es el punto 

central de la arquitectura. Con este desarrollo se puede interactuar con la red EPC 

supuesta, con el hardware de RFD y con el sistema de información empresarial y de 

control de obra representado por un sistema sencillo de base de datos. Fue de 

desarrollado en lenguaje java y con la plataforma eclipse versión 3.0.1 sumado al 

plugin VE 1.0.1. para desarrollos de interface gratifica. 

2. CONFIGURACIÓN  DE LA INTERFAZ : 

 
Lo primero que se debe hacer para que iniciar la aplicación después de haber 

instalado todos los paquetes necesarios es:  

 Ejecutar  el programa EasyPHP, el cual nos permite inicializar la base de 

datos del cliente. 

 Ejecutar la plataforma Eclipse  2.1. con la cual podemos  subir nuestro el 

servidor PML Jboss  y después activar nuestra interfaz  cliente 

GuiMediadorEPc . ver figura 1 

 

 

Figura 1. interfaz Mediador EPC 

Esta interface cliente  integra la consulta  al servidor de PML y tres  submenús, 

diseñados para poder explicar la interacción con toda la arquitectura EPC. Los 

submenús son: Comunicaciones, Programar UID, Leer UID.. 
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2.1 Submenú Comunicaciones:  

Seleccionar el Submenú Comunicaciones, en este menú se establece la 

configuración del puerto RS232 al cual se va conectar el lector RFID.  

 Al cargar el programa por primera ves, se selecciona  el puerto (Comm 1 a 

6), la rata de baudios (38400), la paridad (none) los bits de datos (8) y los bit 

de parada (1). 

 Dar  un click en Guardar , y aparece en la interfaz en la pantalla de 

comandos ubicada a la derecha los valores configurados, ver figura 2. 

 

Figura 2. Submenú Comunicaciones 

 Cada cambio realizado en este submenú queda reflejado en el archivo 

ConfPuerto.xml el cual es guardado  con esta configuración en una carpeta 

de la  aplicación. 

 

2.2 Submenú “Programar UID”. 

 Se selecciona el Submenú “Programar UID”, el cual representa  la acción 

que realiza el proveedor,  consistente  en programar cada Tag de cada  
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objeto que produce, con un valor EPC, que figura en sus bases de datos , 

ver Figura 3. 

 

 

Figura 3. Submenú  Programar UID 

 llenar los campos : Cabecera (2), Fabricante (6) y No _ serie (10) con valores 

en hexadecimal. 

 Dar un clic en “Activar”  para iniciar  la comunicación del puerto RS-232 con 

el lector, la primera ves sale una ventana  con los valores con los cuales se  

configuro el puerto elegido, ver figura 4 

 

Figura 4. Menú de Activación 

 

 Dar un click en “OK” y se cierra la  ventana,  después hacemos click en el 

botón “Programar UID”, con lo cual se graba la Tag con la información 

digitada en los campos. 
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2.3 Submenú “LEER UID” . 

 

Leer UID establece la acción de captura del código EPC de la tag para su posterior 

consulta al servidor PML, cuando un producto ingresa a nuestra bodega . Ver Figura 

5. 

 

Figura  5 Submenú Leer UID 

 Dar  click en activar,  y establecer  la comunicación RS232 con el lector 

 Click en SCAN , con lo cual se lee el código EPC de la tag y se registra  en 

la tabla que contiene los campos  Reg, Cabecera, Fabricante, Articulo y  

No_Serie. 

 Seleccionar en la casilla Reg el número correspondiente del registro 

escaneado y del cual se desea  obtener información , la casilla UID se llena 

con el valor EPC, ver figura 5. 

 Dar un  click en PML, se genera la consulta en el servidor PML y este retorna  

en la ventana de la derecha la información adicional de la tag del producto; 

esta información incluye  proveedor, descripción del producto y las unidades 

del mismo. ver figura 5 
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 Activar el botón SPC?, para realizar una consulta a la base de datos del 

control de obra  o presupuesto, en la cual se encuentra la información que 

describe el producto  y la  ubicación dentro de la obra, ver figura 7.  

 

Figura 6. Consulta SPC? 

 Al estar de acuerdo con la ubicación se procede a relacionar esta 

información con el código EPC que se obtuvo, acción que realiza  el botón 

“Relacionar”  esta nueva información (descripción del producto y ubicación) 

es añadida a la tag, ver figura 7. 

 

Figura 8 Acción Relacionar 

 En el momento en que algún elemento abandone  la bodega y se desea  

conocer  el sitio al cual debe ser trasladado, y se encuentre configurado el 

submenú comunicaciones, al activar el botón  “Ubicación” este entrega un 

mensaje desplegado en una ventana indicando la .ubicación exacta del 

articulo en la obra. y la descripción del mismo. Ver figura 9. 

 

 

Figura 9. Consulta Ubicación. 
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ANEXO C: MODELADO 
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1. Descripción casos de uso del Mediador (Mepcc) 

 

 
A continuación se realiza la descripción de los casos de uso a implementar en el 

sistema Mediador EPC para la construcción- MEPCC. También se hará una 

descripción de los actores del sistema. 

 

1.1 ACTORES DEL SISTEMA 

 

Simulador_PML: Hace las veces de sistema de información EPC y da información 

de los artículos. 

 

MEPCC: Es el sistema principal y realiza varias funciones como: manejo de 

lectores, solicita información de datos al servidor PML, actualiza el sistema de 

control de obras, realiza la programación de las tags para la simulación de 

programación del código EPC. También simula el sistema de control de obras.  

 

Administrador: Usuario del sistema que se encarga de la configuración y 

administración del mismo y del manejo de las tags. 
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1.3 DIAGRAMA DE CASOS DE USO MEPCC 

 

ConfigurarComunicaciones

ProgramarUID

LeerUID
Administrador

UbicarProductoControlObra

ConsultarPML
SimuladorPML

 
 

1.4  CASOS DE USO 

 
A continuación se describe detalladamente los casos de uso del sistema MEPCC. 
 
1.4.1 ConfigurarComunicaciones  
 
Caso de uso No. 1 ConfigurarComunicaciones 

Iniciador Administrador 

Propósito Establecer la configuración del puerto RS232 al cual se va conectar el lector RFID. 

Precondición Tener conectado el lector. 

Escenario ADMINISTRADOR MEPCC 

1. Selecciona del menú de 

COMUNICACIONES de el puerto, 
la rata de baudios, la paridad, los 
bits de datos y los bits de parada. 

 
2. Selecciona el botón Guardar 
 

 

 

 
 
 

 
3. Guarda los cambios realizados en un archivo 
ConfPuerto.xml 

 
4. Aparece en la parte derecha de la pantalla los 
valores configurados. 

 

Poscondición Sistema de comunicación con el lector configurado 

Excepciones  

Interfaz Interfaz 1 
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1.4.2 ProgramarUID 
 
 
 
Caso de uso No. 2 

ProgramarUID 

Iniciador Administrador (Proveedor) 

Propósito Establecer un valor de EPC a una etiqueta de RFID 

Precondición Lector configurado y conectado al sistema MEPCC  

Escenario ADMINISTRADOR MEPCC 

1. Llena los campos de cabecera, fabricante, 
producto y No. de serie con valores 

héxadecimal que toma de su base de 
datos, para armar el código EPC. 

2. Selecciona el botón Activar para iniciar la 

comunicación con el lector 
4. Oprime el botón OK para confirmar la 

configuración del lector. 

5.   Selecciona el botón Programar UID. 

 
 

 
 
3. Muestra una ventana con los valores 

elegidos para la configuración del lector 
para su confirmación. 
 

6. Graba la tag con la información 
digitada en los campos. 

 

Poscondición Código EPC relacionado a una tag. 

 

Excepciones  

Interfaz Interfaz 2 

 
 
 
1.4.3 Leer UID 
 
 
Caso de uso No. 3 

LeerUID 

Iniciador Administrador 

Propósito Capturar dato EPC de la etiqueta de producto. 

Precondición Lector configurado y conectado al sistema MEPCC  
Etiqueta de producto marcada con código EPC 

Escenario ADMINISTRADOR MEPCC 

1. Establece la comunicación con el lector 
oprimiendo el botón Activar del submenú 

Leer UID. 
2. Oprime el botón Scan para capturar la 

información de la tag. 

 
 
 

4.  Ingresa en la casilla Reg. el número de 
registro del cual quiere obtener información. 

 
 

 
3. Registra en la tabla de la pantalla los 
datos relacionados a la tag como 

cabecera, fabricante, artículo y número 
de serie.  
 

5. Despliega en la casilla UID el número 
EPC. 
6. Graba la tag con la información 

digitada en los campos. 
 

Poscondición Captura del código EPC de la tag. 

Excepciones  

Interfaz Interfaz 3. 
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1.4.5 Consultar PML 
 
Caso de uso No. 4 

ConsultarPML 

Iniciador Administrador 

Propósito Consultar la información relacionada con el producto.. 

Precondición Caso de uso No. 3 LeerUID inicializado. 

Escenario ADMINISTRADOR MEPCC 

1. Oprime el botón PML?  
 

2 Genera la consulta al servidor PML 
3 Despliega la información obtenida del servidor PML 
relacionada con la UID consultada, como proveedor, 

descripción del producto, unidades, etc. 
 

 

Poscondición Código EPC relacionado a una tag. 

 

Excepciones  

Interfaz Interfaz 4. 

 
 
1.4.6 UbicarProductoControlObra 
 

 
Caso de uso No. 5 

UbicarProductoControlObra 

Iniciador Administrador 

Propósito Relacionar a un código EPC la ubicación de un producto obtenida de la consulta a la base de 
datos de la obra en la que se encuentra la información que describe el producto y la ubicación 

dentro de la obra 

Precondición Caso de uso No. 3 LeerUID inicializado. 

Escenario ADMINISTRADOR MEPCC 

1. Oprime el botón SPC?  
 

 
4.   Oprime el botón Relacionar  
 

 
6. Oprime el botón Ubicación 

2    Realiza la consulta al servidor PML. 
3. Despliega la descripción del producto y la 

ubicación de él dentro de la obra. 
5.   Se añade al código EPC de la tag la información 
de descripción y ubicación del producto. 

 
7. Despliega un mensaje con la ubicación exacta del 
producto dentro de la obra y su descripción. 

 

Poscondición Código EPC relacionado a una tag. 
 

Excepciones  

Interfaz Interfaz 5. 
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1.5 INTERFACES RELACIONADAS 
 
 
Interfaz 1. Submenú Comunicaciones. 

 

 
 

 

 
Interfaz 2. Programar UID 
 

 
 
Interfaz 3. Leer UID 
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Interfaz 4. Consulta PML 

 
 
 
 
Interfaz 5. Ubicar producto en el control de obra. 

 
 
 
1.6  DIAGRAMA DE DESPLIEGUE 
 
 
 

Servidor 

PML
lector 

RFID

Servidor 

MEPCC
Tags

 
 
 

Protocolo de  
comunicación   
 
 

Aire Tag 
HF 

Protocolo de  
comunicación   
 
 
Lector  Servidor 
    RS232 

Protocolo de  
comunicación   
 
 
TCP / IP  RMI 
Web service 


